Solusi Device eth0 does not seem to be present, delaying initialisation

Apabila anda mengalami problem “Device eth0 does not seem to be present, delaying initialisation” maka berikut ini solusinya.

Singkat cerita, kami mengalami problem “Device eth0 does not seem to be present, delaying initialisation” karena penggantian fisik server ke server baru disebabkan server sebelumnya tidak bisa booting. Nah problem diatas terjadi karena berubahnya hardware address karena perubahan tersebut fisikal server. Yang harus anda lakukan adalah.

Catatan : ini dilakukan pada sistem operasi linux Centos 6.x

  1. Delete file ini. /etc/udev/rules.d/70-persistent-net.rules
  2. reboot server

kemudian lihat file /etc/udev/rules.d/70-persistent-net.rules

nano /etc/udev/rules.d/70-persistent-net.rules

dan keluar seperti ini

# PCI device 0x8086:0x10c9 (igb)
SUBSYSTEM==”net”, ACTION==”add”, DRIVERS==”?*”, ATTR{address}==”00:26:9e:b5:82:a8″, ATTR{type}==”1″, KERNEL==”eth*”, NAME=”eth0″

perhatikan pada bagian ATTR{address}==”00:26:9e:b5:82:a8″

nilai tersebut adalah nomor network hardware anda. kemudian sesuaikan setting network dengan nomor hardware tersebut.

edit disini

nano /etc/sysconfig/network-scripts/ifcfg-eth0

Ubah pada bagian HWADDR sesuai dengan nomor hardware network diatas dan hasilnya kira-kira seperti ini

DEVICE=”eth0″
BOOTPROTO=”static”
DNS1=”8.8.8.8″
DNS2=”8.8.4.4″
GATEWAY=”23.92.215.217″
HWADDR=”00:26:9E:B5:82:A8″
IPADDR=”xxx.xxx.xxx.xxx”
IPV6INIT=”yes”
NETMASK=”255.255.255.248″
NM_CONTROLLED=”yes”
ONBOOT=”yes”
TYPE=”Ethernet”
UUID=”5f8a734c-a59b-4984-b723-440f5a3aa953″

Selanjutnya restart network dan berhasil tidak lagi keluar error eth0 not seem to be present. Selamat mencoba.

Leave a Reply

Your email address will not be published. Required fields are marked *

What is 15 + 10 ?
Please leave these two fields as-is:
IMPORTANT! To be able to proceed, you need to solve the following simple math (so we know that you are a human) :-)

 

Wordpress SEO Plugin by SEOPressor